fibonacci数列_矩阵快速幂

Posted 阿宝的锅锅

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了fibonacci数列_矩阵快速幂相关的知识,希望对你有一定的参考价值。

描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

技术分享.

Given an integer n, your goal is to compute the last 4 digits of Fn.

 

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

技术分享.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

技术分享.

 

 
输入
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1
样例输出
0
34
6875

【题意】

斐波那契数列可以用矩阵来求


技术分享

当求第非常大的一个斐波那契数的后几位时我们可以用矩阵快速幂求解了。

#include<iostream>
#include<stdio.h>
#include<vector>
#include<string.h>
using namespace std;
typedef vector<int>vec;
typedef vector<vec>mat;
const int N=10000;
mat mul(mat a,mat b)//求两个矩阵的乘积
{
    mat c(a.size(),vec(b[0].size()));
    for(int i=0;i<a.size();i++)
    {
        for(int k=0;k<b.size();k++)
        {
            for(int j=0;j<b[0].size();j++)
            {
                c[i][j]=(c[i][j]+a[i][k]*b[k][j])%N;
            }
        }
    }
    return c;
}
mat get_ans(mat a,int n)//矩阵的快速幂
{
    mat b(a.size(),vec(a.size()));
    for(int i=0;i<a.size();i++)
    {
        b[i][i]=1;
    }
    while(n>0)
    {
        if(n&1) b=mul(b,a);
        a=mul(a,a);
        n>>=1;
    }
    return b;
}
int main()
{
    long long int n;
    while(~scanf("%lld",&n),n>=0)
    {
        if(n==-1) break;
        mat a(2,vec(2));
        a[0][0]=1,a[0][1]=1;
        a[1][0]=1,a[1][1]=0;
        a=get_ans(a,n);
        printf("%d\n",a[1][0]);
    }
    return 0;
}

 

 

以上是关于fibonacci数列_矩阵快速幂的主要内容,如果未能解决你的问题,请参考以下文章

Fibonacci数列的矩阵快速幂解法

1250 Fibonacci数列(矩阵乘法快速幂)

矩阵乘法快速幂 codevs 1732 Fibonacci数列 2

poj 3070 Fibonacci(矩阵快速幂求Fibonacci数列)

矩阵乘法快速幂 codevs 1250 Fibonacci数列

POJ3070 Fibonacci(矩阵快速幂加速递推)模板题