HDU 5907 Find Q(字符串)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5907 Find Q(字符串)相关的知识,希望对你有一定的参考价值。

传送门

Description

Byteasar is addicted to the English letter ‘q‘. Now he comes across a string S consisting of lowercase English letters.

He wants to find all the continous substrings of S, which only contain the letter ‘q‘. But this string is really really long, so could you please write a program to help him?

Input

The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.

In each test case, there is a string S, it is guaranteed that S only contains lowercase letters and the length of S is no more than 100000.

Output

For each test case, print a line with an integer, denoting the number of continous substrings of S, which only contain the letter ‘q‘.

Sample Input

2
qoder
quailtyqqq

Sample Output

1
7

思路

题意找出SS的所有仅包含字母‘q‘的连续子串

只要求出每个位置能往右延伸多长即可。

 
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100005;
char a[maxn];

int main()
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
        __int64 res = 0,cnt = 0;
        scanf("%s",a);
        int len = strlen(a);
        for (int i = 0;i < len;)
        {
            if (a[i] == ‘q‘)
            {
                while (a[i] == ‘q‘)
                {
                    i++;
                    cnt++;
                }
                res += (1+cnt)*cnt/2;
                cnt = 0;
            }
            else
            {
                i++;
            }
        }
        printf("%I64d\n",res);
    }
    return 0;
}

  

  

以上是关于HDU 5907 Find Q(字符串)的主要内容,如果未能解决你的问题,请参考以下文章

HDU5907 Find Q 数学

HDU 5980 Find Small A (水题)

hdu 2069 限制个数的母函数

HDU 2203亲和串

hdu6704 后缀数组+主席树+ST +二分

Q - N! HDU - 1042