uva624 01背包要求输出路径

Posted a_clown_cz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了uva624 01背包要求输出路径相关的知识,希望对你有一定的参考价值。

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on
CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How
to choose tracks from CD to get most out of tape space and have as short unused space as possible.
Assumptions:
• number of tracks on the CD does not exceed 20
• no track is longer than N minutes
• tracks do not repeat
• length of each track is expressed as an integer number
• N is also integer
Program should find the set of tracks which fills the tape best and print it in the same sequence as
the tracks are stored on the CD
Input
Any number of lines. Each one contains value N, (after space) number of tracks and durations of the
tracks. For example from first line in sample data: N = 5, number of tracks=3, first track lasts for 1
minute, second one 3 minutes, next one 4 minutes
Output
Set of tracks (and durations) which are the correct solutions and string ‘sum:’ and sum of duration
times.

Sample Input
5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2
 
Sample Output
1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45
 
 
Tip:注意两次循环的方向是相反的。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;

int dp[10005],w[25];
int path[25][10005];

int main()
{
    int m,n;
    while(cin>>m>>n)
    {
        memset(dp,0,sizeof(dp));
        memset(path,0,sizeof(path));
        memset(w,0,sizeof(w));
        for(int i=1; i<=n; i++)
            cin>>w[i];
        for(int i=n; i>=1; i--)
        {
            for(int j=m; j>=w[i]; j--)
            {
                if(dp[j-w[i]]+w[i]>dp[j])
                {
                    dp[j]=dp[j-w[i]]+w[i];
                    path[i][j]=1;
                }
            }
        }
        for(int i=1,j=m; i<=n; i++)
        {
            if(path[i][j]==1)
            {
                cout<<w[i]<< ;
                j-=w[i];
            }
        }
        cout<<"sum:"<<dp[m]<<endl;
    }
    return 0;
}

 

以上是关于uva624 01背包要求输出路径的主要内容,如果未能解决你的问题,请参考以下文章

uva624 CD (01背包+路径的输出)

UVA624(01背包记录路径)

uva 624 CD 01背包打印路径

UVA 624 CD (01背包)

Re0:DP学习之路 01背包如何打印路径?

UVA-624 dp专题A