HDU 1093 A+B for Input-Output Practice (V)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1093 A+B for Input-Output Practice (V)相关的知识,希望对你有一定的参考价值。

Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 
Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
 
Sample Output
10
15
 
题意:输入n,代表n组数据,每组数据包括一个m以及m个数,输出m个数之和
 
#include <stdio.h>
int  main()
{
    int a, sum, n, i, m;
    while (~scanf ("%d", &n)&&n)
    {
        while(n--)
        {
            scanf("%d", &m);
            sum = 0;
            for(i=1;i<=m;i++)
            {
            scanf("%d", &a);
            sum += a;
            }
            printf ("%d\n", sum);
        }
    }
    return 0;
}

 

以上是关于HDU 1093 A+B for Input-Output Practice (V)的主要内容,如果未能解决你的问题,请参考以下文章

Hdu 1093 A+B for Input-Output Practice (V)

(HDU)1093 --A+B for Input-Output Practice (V)(输入输出练习(V))

1093 字符串A+B (20分)

hdu1093

[PAT Basic]1093 字符串A+B

1093 字符串A+B (20 分)