An Easy Task

Posted 92#

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了An Easy Task相关的知识,希望对你有一定的参考价值。

描述

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

输入

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).

输出

For each test case, you should output the Nth leap year from year Y.

样例输入

3
2005 25
1855 12
2004 10000

样例输出

2108
1904
43236

 

code :

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
bool isLoop(int y){
    if((y%4==0 && y%100!=0) || y%400==0){
      return true;
    }
    return false;
}
int main()
{
    int t, y, n;
    cin>>t;
    while(t--){
       cin>>y>>n;
       while(n){
            if(isLoop(y)){
                n--;
            }
            y++;
         }
         cout<<y-1<<endl;
    }

 return 0;
}

  

以上是关于An Easy Task的主要内容,如果未能解决你的问题,请参考以下文章

An Easy Task(简箪题)

HDU An Easy Task

(HDU)1076 --An Easy Task(简单任务)

HDU-1076-An Easy Task(Debian下水题測试.....)

杭电OJ(HDU)-ACMSteps-Chapter Two-《An Easy Task》《Buildings》《decimal system》《Vowel Counting》

ZOJ 3844Easy Task