IBM Minus One

Posted 92#

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了IBM Minus One相关的知识,希望对你有一定的参考价值。

描述

 

You may have heard of the book ‘2001 - A Space Odyssey‘ by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don‘t tell you how the story ends, in case you want to read the book for yourself :-)

After the movie was released and became very popular, there was some discussion as to what the name ‘HAL‘ actually meant. Some thought that it might be an abbreviation for ‘Heuristic ALgorithm‘. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

 

输入

 

The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

 

输出

 

For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing ‘Z‘ by ‘A‘.

Print a blank line after each test case.

 

样例输入

2
HAL
SWERC

样例输出

String #1
IBM

String #2
TXFSD

注意输出格式每一个输出都有一个blank line.

code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    char p[] = {‘A‘,‘B‘,‘C‘,‘D‘,‘E‘,‘F‘,‘G‘,‘H‘,‘I‘,‘J‘,‘K‘,‘L‘,‘M‘,‘N‘,
    ‘O‘,‘P‘,‘Q‘,‘R‘,‘S‘,‘T‘,‘U‘,‘V‘,‘W‘,‘X‘,‘Y‘,‘Z‘};
    int n, x=1;
    string str;
    cin>>n;
    while(n--){
        cin>>str;
        cout<<"String #"<<x<<endl;
        for(int i=0; i<str.length(); i++){
            if(str[i]>=‘A‘ && str[i]<‘Z‘) {
                 cout<<p[str[i]-‘A‘+1];
            }
            if(str[i] == ‘Z‘){
              cout<<"A";
            }
        }
        cout<<endl;
        cout<<endl;
        x++;
    }
 return 0;
}

  

以上是关于IBM Minus One的主要内容,如果未能解决你的问题,请参考以下文章

java.sql.SQLException: Io 异常: Got minus one from a read call

Got minus one from a read call异常

oracle之Io异常: Got minus one from a read call

连接Oracle数据库的时候报了“Got minus one from a read call”

Caught: java.sql.SQLException: Io 异常: Got minus one from a read call;create connection SQLException

SQL的minus