hdu1159 最长公共子序列

Posted a_clown_cz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu1159 最长公共子序列相关的知识,希望对你有一定的参考价值。

Common Subsequence

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

 

Sample Input

abcfbc abfcab

programming contest

abcd mnp

 

Sample Output

4

2

0

 

dp思想,不断更新当前的最长值。

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;

int dp[1010][1010];
char a[1005],b[1005];

int main()
{
    while(cin>>a>>b)
    {
        int len1=strlen(a);
        int len2=strlen(b);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=len1; i++)
            for(int j=1; j<=len2; j++)
                if(a[i-1]==b[j-1])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        cout<<dp[len1][len2]<<endl;
    }
    return 0;
}

 

以上是关于hdu1159 最长公共子序列的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1159 最长公共子序列

hdu 1159 Common Subsequence(最长公共子序列)

hdu 1159 Common Subsequence(dp 最长公共子序列问题LCS)

hdu 1159 Common Subsequence (最长公共子序列)

hdu1159Common Subsequence(最长公共子序列)

HDU 1159 Common Subsequence (动态规划最长公共子序列)