poj 1936 All in All

Posted 邻家那小孩儿

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 1936 All in All相关的知识,希望对你有一定的参考价值。

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

char s[100005],t[100005];
int data[100005];

int main()
{
    int flag,k,m;
    while(scanf("%s%s",s,t)!=-1)
    {
        int lens,lent;
        lens=strlen(s);
        lent=strlen(t);
        k=0;
        flag=0;
        for(int i=0;i<lent;i++)
        {
            if(t[i]==s[0])
            data[k++]=i;
        }
        for(int i=0;i<k;i++)
        {
            m=0;
            for(int j=data[i];j<lent;j++)
            {
                if(t[j]==s[m])
                m++;
                if(m==lens)
                {
                    flag=1;break;
                }
            }
            if(flag) break;
        }
        if(flag) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}

 

以上是关于poj 1936 All in All的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1936 All in All 匹配, 水题 难度:0

POJ 1936 All in All

[POJ1936]All in All

「日常训练」All Friends(POJ-2989)

P59 子序列(All in ALl)

UVa 10340 All in All (水题,匹配)