POJ 1286 Necklace of Beads(项链的珠子)

Posted 丿球痞D小七

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1286 Necklace of Beads(项链的珠子)相关的知识,希望对你有一定的参考价值。

Necklace of Beads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7874   Accepted: 3290

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 
技术分享

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

/*Polya原理*/
#include <cstdio>
#include <iostream>
using namespace std;
long long aaaa(long long a,long long b)
{
    long long res=1,tmp=a;
    while(b) 
    {
        if (b&1) 
            res*=tmp;
        tmp*=tmp;
        b>>=1;
    }
    return res;
}
int gcd(int a,int b) 
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int n;
    while ( ~scanf("%d", &n) && n != -1) 
    {
        long long a = 0, b = 0;
        for (int i=0;i<n;i++) 
        {
            a+=aaaa(3,gcd(i,n));
        } 
        if (n&1) 
            b=(long long)n*aaaa(3,(n+1)/2);
        else 
            b=(long long)n/2*(aaaa(3,n/2+1)+aaaa(3,n/2));
        if (n==0) 
            printf("0\n");
        else 
            printf("%lld\n",(a+b)/2/n);
    }
    return 0;
}

 

以上是关于POJ 1286 Necklace of Beads(项链的珠子)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1286 Necklace of Beads

POJ1286 Necklace of Beads

poj 1286 Necklace of Beads

POJ 1286 Necklace of Beads(项链的珠子)

poj1286 Necklace of Beads—— Polya定理

POJ 1286-Necklace of Beads