HDU 5883 The Best Path

Posted 月夜下

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5883 The Best Path相关的知识,希望对你有一定的参考价值。

The Best Path

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 852    Accepted Submission(s): 359


Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are N lakes, and M rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number (a1,a2,...,an) for each lake. If the path she finds is P0P1...Pt, the lucky number of this trip would be aP0 XOaP1 XO..XOaPt. She want to make this number as large as possible. Can you help her?
 
 
Input
The first line of input contains an integer t, the number of test cases. t test cases follow.

For each test case, in the first line there are two positive integers N (N100000) and M (M500000), as described above. The i-th line of the next N lines contains an integer ai(i,0ai10000) representing the number of the i-th lake.

The i-th line of the next M lines contains two integers ui and vi representing the i-th river between the ui-th lake and vi-th lake. It is possible that ui=vi.
 
 
Output
For each test cases, output the largest lucky number. If it dose not have any path, output "Impossible".
 
 
Sample Input
2
3 2
3
4
5
1 2
2 3
4 3
1
2
3
4
1 2
2 3
2 4
 
 
Sample Output
2
Impossible
 
 
Source
 
 
 
解析:
技术分享
 
 
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAXN = 100000+5;
int a[MAXN];
int degree[MAXN];
int n, m;

void solve()
{
    memset(degree, 0, sizeof(degree));
    scanf("%d%d", &n, &m);
    for(int i = 1; i <= n; ++i)
        scanf("%d", &a[i]);
    int u, v;
    while(m--){
        scanf("%d%d", &u, &v);
        ++degree[u];
        ++degree[v];
    }
    int odd_sum = 0;
    for(int i = 1; i <= n; ++i){
        if(degree[i]&1)
            ++odd_sum;
    }
    if(!(odd_sum == 0 || odd_sum == 2)){
        printf("Impossible\n");
        return;
    }
    int val = 0;
    for(int i = 1; i <= n; ++i){
        if((degree[i]/2)&1)
            val ^= a[i];
    }
    if(odd_sum == 0){
        int res = 0xffffffff;
        for(int i = 1; i <= n; ++i){
            if(degree[i] != 0)
                res = max(res, val^a[i]);
        }
        printf("%d\n", res);
    }
    else{
        int s = 0, e = 0;
        for(int i = 1; i <= n; ++i){
            if(degree[i]&1){
                if(s == 0){
                    s = i;
                }
                else{
                    e = i;
                    break;
                }
            }
        }
        int res = val^a[s]^a[e];
        printf("%d\n", res);
    }
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--){
        solve();
    }
    return 0;
}

  

以上是关于HDU 5883 The Best Path的主要内容,如果未能解决你的问题,请参考以下文章

The Best Path---hdu5883(欧拉路径)

HDU 5883 The Best Path

HDU5883 The Best Path(并查集+欧拉路)

hdu5883:The Best Path 欧拉图的性质和应用

HDU 5883 The Best Path (欧拉路或者欧拉回路)

HDU 5883 The Best Path(并查集+欧拉回路 or 欧拉路)——2016 ACM/ICPC Asia Regional Qingdao Online