HDU 5878 I Count Two Three

Posted 月夜下

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5878 I Count Two Three相关的知识,希望对你有一定的参考价值。

I Count Two Three

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 767    Accepted Submission(s): 403


Problem Description
I will show you the most popular board game in the Shanghai Ingress Resistance Team.
It all started several months ago.
We found out the home address of the enlightened agent Icount2three and decided to draw him out.
Millions of missiles were detonated, but some of them failed.

After the event, we analysed the laws of failed attacks.
It‘s interesting that the i-th attacks failed if and only if i can be rewritten as the form of 2a3b5c7d which a,b,c,d are non-negative integers.

At recent dinner parties, we call the integers with the form 2a3b5c7d "I Count Two Three Numbers".
A related board game with a given positive integer n from one agent, asks all participants the smallest "I Count Two Three Number" no smaller than n.
 

 

Input
The first line of input contains an integer t (1t500000), the number of test cases. t test cases follow. Each test case provides one integer n (1n109).
 

 

Output
For each test case, output one line with only one integer corresponding to the shortest "I Count Two Three Number" no smaller than n.
 

 

Sample Input
10
1
11
13
123
1234
12345
123456
1234567
12345678
123456789
 

 

Sample Output
1
12
14
125
1250
12348
123480
1234800
12348000
123480000
 

 

Source
 
 
 
解析:预处理得到满足条件的数,再二分查询。预处理可参考http://blog.csdn.net/coder_xia/article/details/6707600
 
 
 
#include <cstdio>
#include <algorithm>
#define ll long long
using namespace std;

ll a[10000];

void get(int n)
{
    a[0] = 1;
    int n2 = 0;
    int n3 = 0;
    int n5 = 0;
    int n7 = 0;
    int cnt = 1;
    while(cnt < n){
        ll t1 = min(a[n2]*2, a[n3]*3);
        ll t2 = min(a[n5]*5, a[n7]*7);
        ll t = min(t1, t2);
        if(t == a[n2]*2)
            ++n2;
        if(t == a[n3]*3)
            ++n3;
        if(t == a[n5]*5)
            ++n5;
        if(t == a[n7]*7)
            ++n7;
        a[cnt++] = t;
    }
}

int main()
{
    get(5200);
    int t, n;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        printf("%I64d\n", *lower_bound(a, a+5219, n));
    }
    return 0;
}

  

以上是关于HDU 5878 I Count Two Three的主要内容,如果未能解决你的问题,请参考以下文章

hdu5878 I Count Two Three(二分+ 打表)

HDU 5878 I Count Two Three (打表+二分查找) -2016 ICPC 青岛赛区网络赛

hdu 5878 I Count Two Three (2016 ACM/ICPC Asia Regional Qingdao Online 1001)

[HDOJ5878]I Count Two Three(暴力枚举,二分)

2016 ACM/ICPC Asia Regional Qingdao Online1001 &&hdoj 5878 I Count Two Three

HDU5878