BZOJ 1631==USACO 2007== POJ 3268 Cow Party奶牛派对

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了BZOJ 1631==USACO 2007== POJ 3268 Cow Party奶牛派对相关的知识,希望对你有一定的参考价值。

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 19226   Accepted: 8775

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow‘s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int map[1001][1001],w[1001][1001];
int dis[1001],Team[5000];
bool exist[1001];
int n,m,t;        // exist 为 true 则不可进队 
void SPFA(int s)
{
    int head=0,tail=1,k=0;
    Team[head]=s,exist[s]=true;dis[s]=0;
    while(head<tail)
    {
        k=Team[head];
        exist[k]=false;
        for(int i=1;i<=n;i++)
        {
            if((map[k][i]>0)&&(dis[i]>dis[k]+map[k][i]))
            {
                 dis[i]=map[k][i]+dis[k];
                 if(exist[i]==false)
                 {                     
                     Team[tail++]=i;
                     exist[i]=true;
                }
            }
        }
        head++;
    }
}
int main()
{
    cin>>n>>m>>t;
    memset(map,0x3f,sizeof map );
    memset(w,0x3f,sizeof w );
    memset(dis,0x3f,sizeof dis );
    for(int i=1;i<=m;i++)
    {
        int x,y,z;
        cin>>x>>y>>z;
        map[x][y]=z;
        w[x][y]=z;
    }
    SPFA(t);// 从起点开始到其他每个点找一遍最短路 
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(w[i][j]>w[i][k]+w[k][j])
                   w[i][j]=w[i][k]+w[k][j];
            }
        }
    }
    int max;
    for(int i=1;i<=n;i++)
    {
        if((i==1)||(dis[i]+w[i][t]>max))
           max=dis[i]+w[i][t];
        
    }
    printf("%d",max);
    return 0;
}

思路:一遍SPFA求出起点到其他所有点的最短路,一遍Floyed求出所有点到起点的最短路,两者相加,和最大者即为anwser...

以上是关于BZOJ 1631==USACO 2007== POJ 3268 Cow Party奶牛派对的主要内容,如果未能解决你的问题,请参考以下文章

BZOJ 1631==USACO 2007== POJ 3268 Cow Party奶牛派对

BZOJ 1631 Usaco 2007 Feb. Cow Party

BZOJ1700[Usaco2007 Jan]Problem Solving 解题 动态规划

bzoj 1639: [Usaco2007 Mar]Monthly Expense 月度开支二分

bzoj1690[Usaco2007 Dec]奶牛的旅行 分数规划+Spfa

bzoj 1700: [Usaco2007 Jan]Problem Solving 解题 ——dp