POJ1742(多重部分和问题:模板题)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1742(多重部分和问题:模板题)相关的知识,希望对你有一定的参考价值。

Coins
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 32776   Accepted: 11131

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4
#include"cstdio"
#include"cstring"
using namespace std;
const int MAXN=100005;
int dp[MAXN];
int n,m;
int A[MAXN];
int C[MAXN];
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
    {
        memset(dp,-1,sizeof(dp));
        for(int i=0;i<n;i++)    scanf("%d",&A[i]);
        for(int i=0;i<n;i++)    scanf("%d",&C[i]);
        dp[0]=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<=m;j++)
                if(dp[j]>=0)
                {
                    dp[j]=C[i];
                }
                else if(j<A[i]||dp[j-A[i]]<=0)
                {
                    dp[j]=-1;
                }
                else
                {
                    dp[j]=dp[j-A[i]]-1;
                }
        int ans=0;
        for(int i=1;i<=m;i++)
            if(dp[i]>=0)    ans++;
        printf("%d\n",ans);
    }
    
    return 0;
}

 

以上是关于POJ1742(多重部分和问题:模板题)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1742 Coins ( 经典多重部分和问题 && DP || 多重背包 )

POJ1742 Coins(男人八题之一)

poj1742 多重背包的可行性问题

poj 1742 多重背包问题 dp算法

POJ1742 Coins 多重背包+贪心

poj1742 Coins多重背包贪心