HDU 1556 Color the ball

Posted 勿忘初心0924

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1556 Color the ball相关的知识,希望对你有一定的参考价值。

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17276    Accepted Submission(s): 8640


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

 

Sample Output
1 1 1 3 2 1
 

 

Author
8600
 

 

Source
 

 

Recommend
LL   |   We have carefully selected several similar problems for you:  1166 1542 1394 1698 1255 
/*
每次更新a到b区间就可以了
*/
#include<iostream>
#include<string.h>
#include<stdio.h>
#define N 100010
using namespace std;
int c[N];
int n,a,b;
int lowbit(int x)
{
    return x&(-x);
}

void update(int x,int val)
{
    while(x<=n)
    {
        c[x]+=val;
        x+=lowbit(x);
    }
}

int getsum(int x)
{
    int s=0;
    while(x>0)
    {
        s+=c[x];
        x-=lowbit(x);
    }
    return s;
}

int main()
{
    //freopen("C:\\Users\\acer\\Desktop\\in.txt","r",stdin);
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(c,0,sizeof c);
        //cout<<n<<endl;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            //cout<<a<<" "<<b<<endl;
            update(a,1);//更新状态
            update(b+1,-1);//更新状态
        }
        //cout<<"ok"<<endl;
        for(int i=1;i<n;i++)
        {
            printf("%d ",getsum(i));
            //cout<<i<<endl;
        }    
        printf("%d\n",getsum(n));
    }
    return 0;
}

 

以上是关于HDU 1556 Color the ball的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1556 Color the ball

HDU 1556 Color the ball

HDU——T 1556 Color the ball

hdu 1556 Color the ball (扫描线+树状数组)

hdu1556 Color the ball

HDU - 1556 - Color the ball( 序列的区间操作 )