HDU 3661 Assignments

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 3661 Assignments相关的知识,希望对你有一定的参考价值。

题目链接:

http://acm.split.hdu.edu.cn/showproblem.php?pid=3661

 

Problem Description
In a factory, there are N workers to finish two types of tasks (A and B). Each type has N tasks. Each task of type A needs xi time to finish, and each task of type B needs yj time to finish, now, you, as the boss of the factory, need to make an assignment, which makes sure that every worker could get two tasks, one in type A and one in type B, and, what‘s more, every worker should have task to work with and every task has to be assigned. However, you need to pay extra money to workers who work over the standard working hours, according to the company‘s rule. The calculation method is described as follow: if someone’ working hour t is more than the standard working hour T, you should pay t-T to him. As a thrifty boss, you want know the minimum total of overtime pay.
 

 

Input
There are multiple test cases, in each test case there are 3 lines. First line there are two positive Integers, N (N<=1000) and T (T<=1000), indicating N workers, N task-A and N task-B, standard working hour T. Each of the next two lines has N positive Integers; the first line indicates the needed time for task A1, A2…An (Ai<=1000), and the second line is for B1, B2…Bn (Bi<=1000).
 

 

Output
For each test case output the minimum Overtime wages by an integer in one line.
 

 

Sample Input
2 5
4 2
3 5
 

 

Sample Output
4
 
 
Hint:
题意:
有两个长度为N(N<=1000)的序列A和B,把两个序列中的共2N个数分为N组,使得每组中的两个数分别来自A和B,每组的分数等于max(0,组内两数之和-t),问所有组的分数之和的最小值
题解:
贪心。
代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1000+10;
int a[maxn],b[maxn];
int main()
{
    int n,t;
    while(scanf("%d%d", &n,&t)!=EOF)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&b[i]);
        sort(a,a+n);
        sort(b,b+n);
        int sum=0;
        for(int i=0,j=n-1;i<n;i++,j--)
        {
            if(a[i]+b[j]>t)
                sum+=(a[i]+b[j]-t);
            else
                sum+=0;
        }
        printf("%d\n",sum);
    }
}

  

以上是关于HDU 3661 Assignments的主要内容,如果未能解决你的问题,请参考以下文章

重构改善既有代码设计--重构手法07:Remove Assignments to Parameters (移除对参数的赋值)

UVALive - 3661

如何解决类中分配端点上的错误请求?

POJ 3661 Runing

POJ - 3661 Running

poj3661:Running