POJ1163

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1163相关的知识,希望对你有一定的参考价值。

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 42547   Accepted: 25721

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
#include"cstdio"
#include"cstring"
#include"algorithm"
using namespace std;
const int MAXN=1005;
const int INF=0x3fffffff;
int n;
int a[MAXN][MAXN];
int dp[MAXN][MAXN];
int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        for(int j=0;j<=i;j++)    scanf("%d",&a[i][j]);
    for(int i=n-1;i>=0;i--)
        for(int j=0;j<=i;j++)    
            dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+a[i][j];
    printf("%d\n",dp[0][0]);
    return 0;
}

 

以上是关于POJ1163的主要内容,如果未能解决你的问题,请参考以下文章

POJ1163(简单的DP)

poj 1163 The Triangle

poj-1163-The Triangle

poj1163 - DP递推递归写法

POJ 1163 数字三角形

POJ 1163:The Triangle