POJ 1573 Robot Motion

Posted 月夜下

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1573 Robot Motion相关的知识,希望对你有一定的参考价值。

Robot Motion
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12978   Accepted: 6290

Description

技术分享

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source

 
 
 
解析:模拟。
 
 
 
#include <cstdio>
#include <cstring>

char s[15][15];
int n, m , start;
int dis[15][15];

bool inGrid(int x, int y)
{
    return 1 <= x && x <= n && 1 <= y && y <= m;
}

void solve()
{
    memset(dis, 0, sizeof(dis));
    int time = 0;
    int x = 1, y = start;
    while(1){
        if(!inGrid(x, y)){
            printf("%d step(s) to exit\n", time);
            break;
        }
        if(dis[x][y] != 0){
            printf("%d step(s) before a loop of %d step(s)\n", dis[x][y]-1, time-dis[x][y]+1);
            break;
        }
        dis[x][y] = ++time;
        if(s[x][y] == ‘N‘) --x;
        else if(s[x][y] == ‘S‘) ++x;
        else if(s[x][y] == ‘E‘) ++y;
        else if(s[x][y] == ‘W‘) --y;
    }
}

int main()
{
    while(scanf("%d%d%d", &n, &m, &start), n){
        for(int i = 1; i <= n; ++i)
            scanf("%s", &s[i][1]);
        solve();
    }
    return 0;
}

  

以上是关于POJ 1573 Robot Motion的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1573 Robot Motion

poj1573 Robot Motion

hdu-1573 Robot Motion

PKU 1573 Robot Motion(简单模拟)

POJ1573 ZOJ1708 UVA10116 UVALive5334 HDU1035 Robot MotionDFS+BFS

N - Robot Motion(第二季水)