poj 1328贪心

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 1328贪心相关的知识,希望对你有一定的参考价值。

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
技术分享 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

 

 

 

大概题义就是要在x轴上放圆心,使得放最少的圆可以把所有点覆盖,输出圆的个数

#include <iostream>
#include <string.h>
#include <math.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define Maxn 10010

struct Node{
    double a,b;
}A[Maxn];

bool cmp(Node a,Node b){
    if(a.a != b.a){
        return a.a < b.a;
    }else{
        return a.b < b.b;
    }
}

double wenbao(double R,double high){
    return sqrt( pow(R,2.0) - pow(high,2.0) );
}

int main(){
    int N;
    double R;
    double a,b;
    int count = 1;
    while(cin >> N >> R,N+R){
        bool flag = true;
        for(int i = 0; i < N; i++){
            // cin >> a >> b;
            scanf("%lf%lf",&a,&b);//用scanf,否则会超时
            if(fabs(b) > R){
                flag = false;
            }else{
                double temp = wenbao(R,b);
                A[i].a = a - temp;
                A[i].b = a + temp;
            }
        }
        sort(A,A+N,cmp);
        Node p = A[0];
        int cnt = 1;
        for(int i = 1; i < N; i++){
            if(A[i].a > p.b){
                cnt++;
                p = A[i];
            }else if(A[i].b < p.b){//请仔细思考
                p = A[i];
            }
        }
        if(flag){
            printf("Case %d: %d\n",count++,cnt);
        }else{
            printf("Case %d: -1\n",count++);
        }
    }
}

  

以上是关于poj 1328贪心的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1328 Radar Installation 贪心算法

贪心-poj1328

POJ 1328 Radar Installation 贪心题解

POJ 1328 Radar Installation(贪心)

poj 1328贪心

贪心poj1328:雷达设置