POJ 2039 To and Fro

Posted KennyRom

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2039 To and Fro相关的知识,希望对你有一定的参考价值。

To and Fro

Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There’s no place like home on a snowy night" and there are five columns, Mo would write down 
t o i o y

h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character "x" to pad the message out to make a rectangle, although he could have used any letter. 

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as 

toioynnkpheleaigshareconhtomesnlewx 

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one. 

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

#include<iostream>
#include<string>
using namespace std;
char a[400][400];

int main()
{
    string str;
    int column;

    while (cin >> column&&column != 0)
    {
        cin >> str;

        int row = str.length() / column ;
    
        for (int i = 0; i < row; i++)
            for (int j = 0; j < column; j++)
                a[i][j] = str[i*column + ((i % 2 == 0) ? (j) : (column - j - 1))];
    
        for (int i = 0; i < column; i++)
            for (int j = 0; j < row; ++j)
                cout << a[j][i];
    
        cout << endl;
    }

    return 0;
}

 



以上是关于POJ 2039 To and Fro的主要内容,如果未能解决你的问题,请参考以下文章

[sicily online]1007. To and Fro

[TIA PORTAL][CONVERT] Convert Char Array to DInt...DInt to Char Array..Useful and easy function(代码片段

[RxJS] Implement RxJS `mergeMap` through inner Observables to Subscribe and Pass Values Through(代码片段

项目启动报错Failed to configure a DataSource: 'url' attribute is not specified and no embedde(代码片段

Operator '||' cannot be applied to operands of type 'bool?' and 'bool?'(代码片段

Operator '||' cannot be applied to operands of type 'bool?' and 'bool?'(代码片段