HDU 1228A + B

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1228A + B相关的知识,希望对你有一定的参考价值。

Description

读入两个小于100的正整数A和B,计算A+B. 
需要注意的是:A和B的每一位数字由对应的英文单词给出. 
 

Input

测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出. 
 

Output

对每个测试用例输出1行,即A+B的值. 
 

Sample Input

one + two = three four + five six = zero seven + eight nine = zero + zero =
 

Sample Output

3 90 96
 
#include<stdio.h>
#include<string.h>
char str[1024],letter[10][10]= {"zero","one","two",
"three","four","five","six","seven","eight","nine"};
int flag,a,b,num;
int main()
{
    while(~scanf("%s",str))
    {
        if(strcmp(str,"="))//不为=
        {
            for(int i=0; i<10; i++)
                if(!strcmp(letter[i],str))//为数字i
                {
                    num=i;
                    if(!flag) a=a*10+num;//+前,统计i
                    else b=b*10+num;
                    break;
                }
            if(!strcmp(str,"+")) flag=!flag;//为+
        }
        else
        {
            if(!a&&!b)break;
            printf("%d\n",a+b);
            a=b=0;//不要忘记清零
        }
    }
    return 0;
}

  

 

以上是关于HDU 1228A + B的主要内容,如果未能解决你的问题,请参考以下文章

HDU4057 Rescue the Rabbit(AC自动机+状压DP)

HDU3247 Resource Archiver(AC自动机+BFS+DP)

apriori片段代码

片段 A 的列表视图中的片段 B 中的新列表视图,单击 A 的列表项

使用嵌套片段和动画对象

hdu 1402 A * B Problem Plus(FFT)