[2016-02-04][HDU][1009][FatMouse' Trade]

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[2016-02-04][HDU][1009][FatMouse' Trade]相关的知识,希望对你有一定的参考价值。

[2016-02-04][HDU][1009][FatMouse‘ Trade]

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

 Status

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. 
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 
 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000. 
 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 
 

Sample Input

5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output

13.333 31.500
 
 
 
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1000 + 10;
struct room{ 
    int j,f;
    bool operator < (const room & a)const {
        return ((double)j / f ) > ((double)a.j / a.f ) ;
    }
}r[maxn];

int main(){
    int n,m;
    while(~scanf("%d%d",&m,&n) &&(n != -1 && m != -1)){
        for(int i = 0;i < n;i++){
            scanf("%d%d",&r[i].j,&r[i].f);
        }
        sort(r,r+n);
        double res = 0,left = m;
        for(int i = 0; i < n ;i++){
            if(left >= r[i].f){
                left -= r[i].f;
                res += r[i].j;
            }else {
                res += (left / r[i].f) * r[i].j;
                break;
            }    
        }    
        printf("%.3f\\n",res);
    }
    return 0;
}

 



以上是关于[2016-02-04][HDU][1009][FatMouse' Trade]的主要内容,如果未能解决你的问题,请参考以下文章

HDU1009

[2016-02-04][HDU][1053][Entropy]

HDU-1009的解题报告

hdu1009

hdu1009

HDU 1009 FatMouse' Trade