POJ4768(二分区间)

Posted vCoders

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ4768(二分区间)相关的知识,希望对你有一定的参考价值。

Flyer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2795    Accepted Submission(s): 1051


Problem Description
The new semester begins! Different kinds of student societies are all trying to advertise themselves, by giving flyers to the students for introducing the society. However, due to the fund shortage, the flyers of a society can only be distributed to a part of the students. There are too many, too many students in our university, labeled from 1 to 2^32. And there are totally N student societies, where the i-th society will deliver flyers to the students with label A_i, A_i+C_i,A_i+2*C_i,…A_i+k*C_i (A_i+k*C_i<=B_i, A_i+(k+1)*C_i>B_i). We call a student "unlucky" if he/she gets odd pieces of flyers. Unfortunately, not everyone is lucky. Yet, no worries; there is at most one student who is unlucky. Could you help us find out who the unfortunate dude (if any) is? So that we can comfort him by treating him to a big meal!
 

 

Input
There are multiple test cases. For each test case, the first line contains a number N (0 < N <= 20000) indicating the number of societies. Then for each of the following N lines, there are three non-negative integers A_i, B_i, C_i (smaller than 2^31, A_i <= B_i) as stated above. Your program should proceed to the end of the file.
 

 

Output
For each test case, if there is no unlucky student, print "DC Qiang is unhappy." (excluding the quotation mark), in a single line. Otherwise print two integers, i.e., the label of the unlucky student and the number of flyers he/she gets, in a single line.
 

 

Sample Input
2
1 10 1
2 10 1
4
5 20 7
6 14 3
5 9 1
7 21 12
 
Sample Output
1 1
8 1
 
思路:二分枚举区间(l,r],mid=(l+r)/2。若(l,mid]出现的数字次数之和为奇数,由奇数+偶数为奇数可得,答案必在(l,mid]内。否则,在(mid,r]区间内。
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN=20005;
typedef long long LL;
struct Node{
    LL a,b,c;
}soc[MAXN];
int n;
bool test(LL hold)
{
    LL s=0;
    for(int i=0;i<n;i++)
    {
        LL limit=min(hold,soc[i].b);
        if(limit>=soc[i].a)
        {
            s=s+(limit-soc[i].a)/soc[i].c+1;
        }
    }
    return (s%2)==1;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%lld%lld%lld",&soc[i].a,&soc[i].b,&soc[i].c);
        }
        LL l=0,r=1LL<<31;
        if(!test(r))
        {
            printf("DC Qiang is unhappy.\n");
            continue;
        }
        else
        {
            while(r-l>1)
            {
                LL mid=(l+r)>>1;
                if(test(mid))
                {
                    r=mid;
                }
                else
                {
                    l=mid;
                }
            }
            LL sum=0;
            for(int i=0;i<n;i++)
            {
                if(soc[i].a<=r&&r<=soc[i].b)
                {
                    if((r-soc[i].a)%soc[i].c==0)
                    {
                        sum++;
                    }
                }
            }
            printf("%lld %lld\n",r,sum);
        }
    }
    return 0;
}

 

异或运算也能过。

#include <cstdio>
using namespace std;
const int MAXN=20005;
struct Node{
    int a,b,c;
}soc[MAXN];
int n;
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&soc[i].a,&soc[i].b,&soc[i].c);
        }
        long long ans=0;
        for(int i=0;i<n;i++)
        {
            for(long long j=soc[i].a;j<=soc[i].b;j+=soc[i].c)
            {
                ans^=j;
            }
        }
        if(ans!=0)
        {
            int sum=0;
            for(int i=0;i<n;i++)
            {
                for(long long j=soc[i].a;j<=soc[i].b;j+=soc[i].c)
                {
                    if(j==ans)
                    {
                        sum++;
                    }
                }
            }
            printf("%lld %d\n",ans,sum);
        }
        else
        {
            printf("DC Qiang is unhappy.\n");
        }
    }
    return 0;
}

 

 

以上是关于POJ4768(二分区间)的主要内容,如果未能解决你的问题,请参考以下文章

hdu 4768 二分

hdu4768二分答案

POJ2104 K-th Number(线段树,二分,vector)

整体二分初探 两类区间第K大问题 poj2104 & hdu5412

POJ2318判断点在直线哪一侧+二分查找区间

poj 2452(RMQ+二分查找)