问题 E: C#统计字符出现的个数

Posted 青衫客36

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了问题 E: C#统计字符出现的个数相关的知识,希望对你有一定的参考价值。

题目描述

编写一个实例方法getCountChar方法。该方法参数有两个,第一个参数可以是字符串s,第二个参数为字符c,方法返回值为第二个参数在第一个参数中出现次数。例如,CountChar("6221982",‘2‘)返回值为3。
部分程序代码已经给出。
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string str = Console.ReadLine();     
            char ch = (char) Console.Read();
            Program pro = new Program();
            Console.WriteLine(pro.getCountChar(str,ch));

            //Console.ReadKey();
        }
        public int getCountChar(String s,char c){
        //


        在此处填写代码


        //
        }
    }
}
 
提交时,请提交整个题目!!!

输入

一个字符串s,一个字符c

输出

该字符c在字符串s中的出现次数

样例输入

6221982
2

样例输出

3

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
 
namespace 统计字符串中数字字符的个数
{
 
    class Program
    {
        static void Main(string[] args)
        {
            string str = Console.ReadLine();
            char ch = (char)Console.Read();
            Program pro = new Program();
            Console.WriteLine(pro.getCountChar(str, ch));
 
            //Console.ReadKey();
        }
        public int getCountChar(String s, char c){
         // 
 
            int num = 0;
            for (int i = 0; i < s.Length; ++i)
            {
                if (s[i] == c)
                {
                    num++;
                }
            }
            return num;
 
        // 
        }
    }
}

  

以上是关于问题 E: C#统计字符出现的个数的主要内容,如果未能解决你的问题,请参考以下文章

python中如何统计字符串中各个字母的个数

C#:统计字符串中每个字符的个数

C#科学计数字符串,如“7.1e-003”转换为decimal类型数据

问题 C: c#统计字符串中数字字符的个数

c#窗体编写程序,统计所给字符串中字母的个数、数字的个数和大写字母的个数,各种控件?

JAVA实验--统计文章中单词的个数并排序