问题 C: c#统计字符串中数字字符的个数

Posted 青衫客36

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了问题 C: c#统计字符串中数字字符的个数相关的知识,希望对你有一定的参考价值。

题目描述

假设有一个GetNumber方法(参数为字符串strSource),编写一个静态方法可以用来统计字符串strSource中数字字符的个数。

输入

输入一个字符串strSource

输出

strSource字符串中数字字符的个数

样例输入

.wrapper {position: relative;} #input {position: absolute;top: 0;left: 0;opacity: 0;z-index: -10;}

asffkl8asjkfjklas3jdf9lkj!

样例输出

3
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
 
namespace 统计字符串中数字字符的个数
{
    class Program
    {
        static void Main(string[] args)
        {
            string s = Console.ReadLine();
            int count = 0;
            for (int i = 0; i < s.Length; ++i)
            {
                if (s[i] >= ‘0‘ && s[i] <= ‘9‘)
                {
                    count++;
                }
            }
            Console.WriteLine(count);
        }
    }
}

  

以上是关于问题 C: c#统计字符串中数字字符的个数的主要内容,如果未能解决你的问题,请参考以下文章

C#写程序,统计所给字符串中字母的个数、数字的个数和大写字母的个数

问题 E: C#统计字符出现的个数

C++ 输入一行字符,分别统计出其中英文字母个数~~

c语言中怎样统计字符串中包含英文字母的个数?

C语言 统计字符串中的数字字符个数

C语言编程题:从键盘输入一串字符,统计其中的数字与字母个数并输出