题目1460:Oil Deposit

Posted 多思考&&多动手

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了题目1460:Oil Deposit相关的知识,希望对你有一定的参考价值。

题目1460:Oil Deposit

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:1405

解决:680

题目描述:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

输入:

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

输出:

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

样例输入:
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
样例输出:
0
1
2
2
#include<iostream>
#include<stdio.h>
#include<queue>
#include<string>
#include<string.h>
using namespace std;


char maze[101][101];//保存地图信息
bool mark[101][101];//为图上每一个点设立一个状态
int n,m;//地图大小为n*m
int go[][2]=    //8个相邻点与当前位置的坐标差
{
    {1,0},
    {-1,0},
    {0,1},
    {0,-1},
    {1,1},
    {1,-1},
    {-1,-1},
    {-1,1}
};

void DFS(int x,int y)//递归遍历所有与x,y直接或间接相邻的@
{
    for(int i=0; i<8; i++) //遍历8个相邻点
    {
        int nx= x+go[i][0];
        int ny=y+go[i][1];
        if(nx<1||nx>n||ny<1||ny>m)  continue;
        if(maze[nx][ny]==*) continue;//该位置不是 @
        if(mark[nx][ny]==true) continue;//该位置已被计算过
        mark[nx][ny]=true;//标记该位置为已经计算
        DFS(nx,ny);//递归查询与该相领位置直接相邻的点
    }
    return;
}


int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)  break;
        for(int i=1; i<=n; i++)
        {
            scanf("%s",maze[i]+1);//第i行地图信息保存在maze[i][1]到maze[i][m]中
        }//按行为单位输入地图信息

        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
            {
                mark[i][j]=false;
            }//初始化所有位置未被计算
        int ans=0;//初始化快计数器
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)//按顺序遍历图中所有位置
            {
                if(mark[i][j]==true)  continue;//若该位置已被处理,跳过
                if(maze[i][j]==*) continue;//若该位置不为@,跳过
                DFS(i,j);
                ans++;
            }
        printf("%d\n",ans);
    }
    return 0;
}

 

以上是关于题目1460:Oil Deposit的主要内容,如果未能解决你的问题,请参考以下文章

Oil Deposit

DFS——hdu1241Oil Deposits

BZOJ 1177 [Apio2009]Oil(递推)

Oil Deposits(油田问题)

题目--oil Deposits(油田) 基础DFS(深度搜索)

LeetCode 1460. 通过翻转子数组使两个数组相等