POJ 2253 Frogger (求每条路径中最大值的最小值,Dijkstra变形)

Posted 季末Despaire

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2253 Frogger (求每条路径中最大值的最小值,Dijkstra变形)相关的知识,希望对你有一定的参考价值。

Frogger

Time Limit: 1000MS Memory Limit: 65536K

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists‘ sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona‘s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog‘s jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy‘s stone, Fiona‘s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy‘s and Fiona‘s stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy‘s stone, stone #2 is Fiona‘s stone, the other n-2 stones are unoccupied. There‘s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:就是让你求从1到2的路径所经过的最大权值的最小值
分析:
用Dijkstra的变形,每个路径的长度是这条路径所经过的最大权值
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
using namespace std;

const int MAXN = 210;

pair<int,int>p[MAXN];

double getdist(pair<int,int>p1,pair<int,int>p2)
{
    return sqrt((double)(p1.first-p2.first)*(p1.first-p2.first)+(p1.second-p2.second)*(p1.second-p2.second));
}

const double INF = 1e20;
double cost[MAXN][MAXN];
double dis[MAXN];
bool vis[MAXN];

void Dijkstra(int n,int st)
{
    for(int i=1;i<=n;i++){
        dis[i]=INF;
        vis[i]=false;
    }
    dis[st]=0;
    for(int j=0;j<n;j++){
        int k=-1;
        double Min=INF;
        for(int i=1;i<=n;i++){
            if(!vis[i]&&Min>dis[i]){
                Min=dis[i];
                k=i;
            }
        }
        if(k==-1) break;
        vis[k]=true;
        for(int i=1;i<=n;i++)
            if(!vis[i]&&max(dis[k],cost[k][i])<dis[i])
                dis[i]=max(dis[k],cost[k][i]);
    }
}

int main()
{
    int n;
    int x,y;
    int iCase=0;
    while(scanf("%d",&n)==1&&n){
        iCase++;
        for(int i=1;i<=n;i++){
            scanf("%d%d",&x,&y);
            p[i]=make_pair(x,y);
        }
        for(int i=1;i<=n;i++){
            for(int j=i;j<=n;j++){
                if(i==j) cost[i][j]=0.0;
                else cost[i][j]=cost[j][i]=getdist(p[i],p[j]);
            }
        }
        Dijkstra(n,1);
        printf("Scenario #%d\n",iCase);
        printf("Frog Distance = %.3f\n\n",dis[2]);

    }
    return 0;
}

 



以上是关于POJ 2253 Frogger (求每条路径中最大值的最小值,Dijkstra变形)的主要内容,如果未能解决你的问题,请参考以下文章

[ACM] POJ 2253 Frogger (最短路径变形,每条通路中的最长边的最小值)

POJ-2253 Frogger---最短路变形&&最大边的最小值

[2016-04-02][POJ][2253][Frogger]

POJ-2253 Frogger dijsktra查找间隔最小的路径

POJ-2253 Frogger(最短路)

POJ-2253-Frogger +最短路小变形