POJ2531:Network Saboteur

Posted vCoders

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2531:Network Saboteur相关的知识,希望对你有一定的参考价值。

Network Saboteur
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10978   Accepted: 5290

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

方法1:不是在集合A就是在集合B,一一枚举尝试。
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN=25;
int c[MAXN][MAXN];
int n;
int res;
int unit[MAXN];
void dfs(int dep)
{
    if(dep==n)
    {
        int ans=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<i;j++)
                if(unit[i]!=unit[j])
                {
                    ans+=c[i][j];
                }
        if(ans>res)    res=ans;
        return ;
    }
    unit[dep]=0;
    dfs(dep+1);
    unit[dep]=1;
    dfs(dep+1);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        res=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf("%d",&c[i][j]);
        dfs(0);
        printf("%d\n",res);
    }
    return 0;
}

方法2:参考别人的代码,很巧妙地DFS。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN=25;
int n;
int belong[MAXN];
int c[MAXN][MAXN];
int res;
void dfs(int dep,int data)
{
    belong[dep]=1;
    int tmp=data;
    for(int i=0;i<n;i++)
    {
        if(belong[i]==0)
            tmp+=c[i][dep];
        else
            tmp-=c[i][dep];
    }
    if(tmp>res)    res=tmp;
    for(int i=dep+1;i<n;i++)
    {
        dfs(i,tmp);
        belong[i]=0;
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        res=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf("%d",&c[i][j]);
        dfs(0,0);
        printf("%d\n",res);
    }
    return 0;
}

 

以上是关于POJ2531:Network Saboteur的主要内容,如果未能解决你的问题,请参考以下文章

带权并查集(含种类并查集)经典模板 例题:①POJ 1182 食物链(经典)②HDU - 1829 A bug's life(简单) ③hihoCoder 1515 : 分数调查(示例代码(代

POJ 3177--Redundant Paths无向图添加最少的边成为边双连通图 &amp;&amp; tarjan求ebc &amp;&amp; 缩点构造缩点树(代

bzoj1593/poj3667

POJ 3134 IDDFS

POJ 3122 (集训比赛2B_B题)解题报告

POJ 2449 第k短路