Tree Recovery

Posted shallow-dream

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Tree Recovery相关的知识,希望对你有一定的参考价值。

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

         D
        / \
       /   \
      B     E
     / \     \
    /   \     \
   A     C     G
              /
             /
            F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!


Input

The input will contain one or more test cases.

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

 


<b< dd="">

Output

For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).

 


<b< dd="">

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

 


<b< dd="">

Sample Output

ACBFGED
CDAB

 

 

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e6+10;
const int INF =0x3f3f3f3f;
//#define LOCAL
#define FOR(i,start,end) for(int i=start;i<=end;i++)
#define FOR_(i,end,start) for(int i=end;i>=start;i--)
#define TLE ios::sync_with_stdio(false)
#define cc cout<<
typedef long long ll;
typedef struct node

    char ch;
    struct node *l,*r;
 node , *link;
node no[60];
string s1,s2;
int j=0;
void  creat(int st , int en)

    int i;
    if(st>en) return ;
    for(i=0;i<en;i++)
        if(s2[i]==s1[j])
            break;
    j++;
    creat(st,i-1);
    creat (i+1,en);
    cout<<s2[i];


int main()

    while(cin>>s1>>s2)
    
        j=0;
        creat( 0,s2.length()-1 );
        cc  endl;
    

 

以上是关于Tree Recovery的主要内容,如果未能解决你的问题,请参考以下文章

如何解释 sklearn.tree.tree_tree.value 属性的(意外)值?

Mysql B-Tree和B+Tree索引

100. Same Tree(Tree)

tree 的递归算法

prune.tree 中的错误无法修剪 R.tree 中的单节点树

误删tree命令如何恢复