Strategic game POJ - 1463 最小点覆盖集

Posted pengge666

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Strategic game POJ - 1463 最小点覆盖集相关的知识,希望对你有一定的参考价值。

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:
技术图片

the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

  • the number of nodes
  • the description of each node in the following format
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
    or
    node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2。
题意:在无向图中,在某一点放置士兵,该士兵可以守护与该点相邻的其他点,求出要保护所有点的最少士兵数。
思路:求最小点覆盖。。最小点覆盖数 = 最大匹配数
AC代码:
#include <algorithm>
#include <string.h>
#include <cstdio>
#include <vector>

using namespace std;
#define maxn 2500
int vis[maxn];
int match[maxn];
vector<int> v[maxn]; 
int n;
int dfs(int u) // 匈牙利模板
    for(int i=0;i<v[u].size();i++)
        int temp=v[u][i];
        if(vis[temp]==0)
            vis[temp]=1;
            if(match[temp]==0||dfs(match[temp]))
                match[temp]=u;
                return 1;
            
        
    
    return 0;

int main()
    while(~scanf("%d",&n))
        for(int i=0;i<=n;i++)
            v[i].clear();
        for(int i=1;i<=n;i++)
            int x,m,y;
            scanf("%d:(%d)",&x,&m);
            for(int j=0;j<m;j++)
                scanf("%d",&y);
                v[x].push_back(y);
                v[y].push_back(x);
            
        
        memset(match,0,sizeof(match));
        int ans=0;
        for(int i=0;i<n;i++)
            memset(vis,0,sizeof(vis));
            if(dfs(i))
                ans++;
        
        printf("%d\n",ans/2);
    
    return 0;

 



以上是关于Strategic game POJ - 1463 最小点覆盖集的主要内容,如果未能解决你的问题,请参考以下文章

poj1463 Strategic game

Strategic game(POJ 1463 树形DP)

Strategic game POJ - 1463 最小点覆盖集

POJ1463 Strategic game

POJ1463 Strategic game (最小点覆盖 or 树dp)

POJ1463&BUCU5973——战略游戏(中文版Strategic game)——题解