PAT Advanced 1152 Google Recruitment (20 分)

Posted littlepage

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT Advanced 1152 Google Recruitment (20 分)相关的知识,希望对你有一定的参考价值。

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google‘s hiring process by visiting this website.

技术图片

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google‘s question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404


#include <iostream>
#include <cmath>
#include <cstdlib>

using namespace std;
//judge is prime
bool isPrime(int num)
    if(num==2||num==3) return true;
    for(int i=2;i<=sqrt(num);i++)
        if(num%i==0) return false;
    
    return true;


int main()

    int len,prime_len;string str;
    cin>>len>>prime_len>>str;
    for(int i=0;i<=(len-prime_len);i++)
        int tmp=atoi(str.substr(i,prime_len).data());
        if(isPrime(tmp))
            cout<<str.substr(i,prime_len);
            system("pause");
            return 0;
        
    
    cout<<404;
    system("pause");
    return 0;

 

以上是关于PAT Advanced 1152 Google Recruitment (20 分)的主要内容,如果未能解决你的问题,请参考以下文章

PAT Advanced 1102 Invert a Binary Tree (25分)

1102. Invert a Binary Tree (25)二叉树——PAT (Advanced Level) Practise

1102. Invert a Binary Tree (25)二叉树——PAT (Advanced Level) Practise

1102. Invert a Binary Tree (25)二叉树——PAT (Advanced Level) Practise

PAT (Advanced Level) 1025. PAT Ranking (25)

1093. Count PAT's (25)计数——PAT (Advanced Level) Practise