B. Light bulbs(2019 ICPC上海站)
Posted lusiqi
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了B. Light bulbs(2019 ICPC上海站)相关的知识,希望对你有一定的参考价值。
There are NN light bulbs indexed from 00 to N-1N−1. Initially, all of them are off.
A FLIP operation switches the state of a contiguous subset of bulbs. FLIP(L, R)FLIP(L,R)means to flip all bulbs xx such that L \leq x \leq RL≤x≤R. So for example, FLIP(3, 5)FLIP(3,5) means to flip bulbs 33 , 44 and 55, and FLIP(5, 5)FLIP(5,5) means to flip bulb 55.
Given the value of NN and a sequence of MMflips, count the number of light bulbs that will be on at the end state.
InputFile
The first line of the input gives the number of test cases, TT. TT test cases follow. Each test case starts with a line containing two integers NN and MM, the number of light bulbs and the number of operations, respectively. Then, there are MMmore lines, the ii-th of which contains the two integers L_iLi? and R_iRi?, indicating that the ii-th operation would like to flip all the bulbs from L_iLi? to R_iRi? , inclusive.
1 \leq T \leq 10001≤T≤1000
1 \leq N \leq 10^61≤N≤106
1 \leq M \leq 10001≤M≤1000
0 \leq L_i \leq R_i \leq N-10≤Li?≤Ri?≤N−1
OutputFile
For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 11) and yy is the number of light bulbs that will be on at the end state, as described above.
样例输入
2 10 2 2 6 4 8 6 3 1 1 2 3 3 4
样例输出
Case #1: 4 Case #2: 3
代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e6+20;
int num[maxn*2];
int main()
int t;
cin>>t;
for(int i=1;i<=t;i++)
int n,m;
scanf("%d%d",&n,&m);
int count = 0;
for(int j = 0; j<m;j++)
int x,y;
scanf("%d%d",&x,&y);
num[count++] = x;
num[count++] = y+1;
sort(num,num+m*2);
int sum = 0;
for(int i = 0;i <count;i+=2)
sum +=num[i+1] - num[i];
printf("Case #%d: %d\n",i,sum);
return 0;
思路:
有一点差分的思想,但是却进行了一定的改变
以上是关于B. Light bulbs(2019 ICPC上海站)的主要内容,如果未能解决你的问题,请参考以下文章
2019上海icpc网络赛B. Light bulbs(思维+差分)
The Preliminary Contest for ICPC Asia Shanghai 2019 B. Light bulbs
The Preliminary Contest for ICPC Asia Shanghai 2019 B. Light bulbs