PAT 甲级 1058 A+B in Hogwarts (20 分) (简单题)

Posted caiyishuai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 甲级 1058 A+B in Hogwarts (20 分) (简单题)相关的知识,希望对你有一定的参考价值。

1058 A+B in Hogwarts (20 分)
 

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it‘s easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

 

题意:

17个Sickle对换一个Galleon,29个Knut对换一个Sickle。根据Galleon.Sickle.Knut的方式相加A和B
分析:把A和B都化为Knut的形式,然后相加,最后转换为Galleon.Sickle.Knut的形式。

AC代码:

#include<iostream>
using namespace std;
int a1,b1,c1,a2,b2,c2;
int main()
    scanf("%d.%d.%d %d.%d.%d",&a1,&b1,&c1,&a2,&b2,&c2);
    a1+=a2;
    b1+=b2;
    c1+=c2;
    int x=c1/29;
    c1-=x*29;
    b1+=x;
    x=b1/17;
    b1-=x*17;
    a1+=x;
    printf("%d.%d.%d",a1,b1,c1);
    return 0;

 

以上是关于PAT 甲级 1058 A+B in Hogwarts (20 分) (简单题)的主要内容,如果未能解决你的问题,请参考以下文章

PAT 甲级 A1058 (2019/02/09)

PAT1058:A+B in Hogwarts

pat 1058 A+B in Hogwarts(20 分)

PAT1058 A+B in Hogwarts

PAT A1058 A+B in Hogwarts (20)[进制转换]

PAT-进制转换-A1058 A+B in Hogwarts (20分)