Digit sum-----The Preliminary Contest for ICPC Asia Shanghai 2019

Posted 0xiaoyu

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Digit sum-----The Preliminary Contest for ICPC Asia Shanghai 2019相关的知识,希望对你有一定的参考价值。

A digit sum S_b(n)Sb?(n) is a sum of the base-bb digits of nn. Such as S_10(233) = 2 + 3 + 3 = 8S10?(233)=2+3+3=8, S_2(8)=1 + 0 + 0 = 1S2?(8)=1+0+0=1, S_2(7)=1 + 1 + 1 = 3S2?(7)=1+1+1=3.

Given NN and bb, you need to calculate \sum_n=1^N S_b(n)n=1N?Sb?(n).

InputFile

The first line of the input gives the number of test cases, TT. TT test cases follow. Each test case starts with a line containing two integers NN and bb.

1 \leq T \leq 1000001T100000

1 \leq N \leq 10^61N106

2 \leq b \leq 102b10

OutputFile

For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 11) and yy is answer.

样例输入

2
10 10 8 2

样例输出

Case #1: 46
Case #2: 13
#include <stdio.h>

int main()

    long long t, tot, n, b, a[15], x, num, sum, i, j, N, temp;
    for(i=0;i<13;i++)
    
        a[i] = i;
    
    scanf("%lld", &t);
    tot = 0;
    while(t--)
    
        scanf("%lld %lld", &n, &b);
        temp = (b-1)*b/2;
        x = 1;
        sum = 0;
        while(n>=x)
        
            sum = sum + temp * x * (n / (x * b));
            N = n % (x * b);
            num = 0;
            for(j=0;j+x<=N;j+=x)
            
                if(num==b) num = 0;
                sum = sum + a[num] * x;
                num++;
            
            if(num==b) num=0;
            sum = sum + a[num]*(N-j+1);
            x *= b;
        
        tot++;
        printf("Case #%lld: %lld\n", tot, sum);
    
    return 0;

 

 

 

 



以上是关于Digit sum-----The Preliminary Contest for ICPC Asia Shanghai 2019的主要内容,如果未能解决你的问题,请参考以下文章

CF 914 G Sum the Fibonacci —— 子集卷积,FWT

CF914G Sum the Fibonacci FWT子集卷积

CF914G Sum the Fibonacci(FWT,FST)

HDU1899 Sum the K-th's

Character.digit()的意义

Backward Digit Sums(暴力)