最长公共子序列

Posted tingtin

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了最长公共子序列相关的知识,希望对你有一定的参考价值。

//poj  1458
Common Subsequence
Time Limit: 1000MS        Memory Limit: 10000K
Total Submissions: 69884        Accepted: 29304
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp
Sample Output

4
2
0

 

 

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define N 1000
char s[N],p[N];
int ls,lp,dp[N][N];
//dp[i][j] :s[0]~s[i-1]与p[0]~p[j-1]的最长公共子序列长度
int main()

    while(~scanf("%s%s",&s,&p))
        ls=strlen(s);lp=strlen(p);
        memset(dp,0,sizeof(dp));
        for(int i =1;i<=ls;i++)
            for(int j=1;j<=lp;j++)
                if(s[i-1]==p[j-1])
                    dp[i][j] = dp[i-1][j-1]+1;
                
                else
                    dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
                
            
        
        printf("%d\n",dp[ls][lp]);
    
    return 0;
  

 

 

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define N 1000
char s[N],p[N];
int ls,lp,dp[N][N];
int flag [N][N];
void print(int i,int j)
    if(i==0&&j==0) return ;
    if(!flag[i][j]) 
        print(i-1,j-1);
        printf("%c",s[i-1]) ;//只有共同才打印 
    
    else if(flag[i][j]==1)
        print(i-1,j);
    
    else
        print(i,j-1);
    

int main()

    while(~scanf("%s%s",&s,&p))
        ls=strlen(s);lp=strlen(p);
        memset(dp,0,sizeof(dp));
        memset(flag,0,sizeof(flag));
        for(int i =1;i<=ls;i++)
            for(int j=1;j<=lp;j++)
                if(s[i-1]==p[j-1])
                    dp[i][j] = dp[i-1][j-1]+1;
                    flag[i][j] = 0;
                
                else
                
                    if(dp[i-1][j]>dp[i][j-1])
                        flag [i][j] =1;
                        dp[i][j] = dp[i-1][j];
                    
                    else
                        flag  [i][j] =-1;
                        dp[i][j] = dp[i] [j-1];
                    
                
                
            
        
        print(ls,lp);//打印出来 
    
    return 0;
  

 

以上是关于最长公共子序列的主要内容,如果未能解决你的问题,请参考以下文章

最长公共子序列的应用

C语言实现最长公共子串与最长公共子序列

最长递增子序列 && 最大子序列最长递增子序列最长公共子串最长公共子序列字符串编辑距离

codevs 1862 最长公共子序列(求最长公共子序列长度并统计最长公共子序列的个数)

最长公共子串和最长公共子序列

最长公共子串与最长公共子序列