hdu1710 二叉树

Posted lyj1

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu1710 二叉树相关的知识,希望对你有一定的参考价值。

Binary Tree Traversals

 

Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
技术图片
 

 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

 

Sample Input
9
9 1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6
 

 

Sample Output
7 4 2 8 9 5 6 3 1
 
//ECUST luoyongjun
#include <bits/stdc++.h>
using namespace std;
const int N = 1010;
int pre[N], in[N], post[N];  //先序、中序、后序
int k;
struct node
    int value;
    node *l, *r;
    node(int value = 0, node *l = NULL, node *r = NULL):value(value), l(l), r(r)
;
void buildtree(int l, int r, int &t, node* &root)  //建树
    int flag = -1;
    for(int i = l; i <= r; i++) //先序的第一个是根,找到对应的中序的位置
        if(in[i] == pre[t])
            flag = i; break;
        
    if(flag == -1) return;       //结束
    root = new node(in[flag]);   //新建结点
    t++;
    if(flag > l)  buildtree(l, flag - 1, t, root ->l);
    if(flag < r)  buildtree(flag + 1, r, t, root ->r);

void preorder (node *root)       //求先序序列
    if(root != NULL)
        post[k++] = root ->value;  //输出
        preorder (root ->l);
        preorder (root ->r);
    

void inorder (node *root)        //求中序序列
    if(root != NULL)
        inorder (root ->l);
        post[k++] = root ->value;  //输出
        inorder (root ->r);
    

void postorder (node *root)      //求后序序列
    if(root != NULL)
        postorder (root ->l);
        postorder (root ->r);
        post[k++] = root ->value;  //输出
    

void remove_tree(node *root)      //释放空间
    if(root == NULL) return;
    remove_tree(root->l);
    remove_tree(root->r);
    delete root;

int main()
    int n;
    while(~scanf("%d", &n))
        for(int i=1;i<=n;i++) scanf("%d", &pre[i]);
        for(int j=1;j<=n;j++) scanf("%d", &in[j]);
        node *root;
        int t = 1;
        buildtree(1, n, t, root);
        k = 0;           //记录结点个数
        postorder(root);
        for(int i=0;i<k;i++) printf("%d%c",post[i],i==k-1?‘\n‘:‘ ‘);
          //作为验证,这里可以用preorder()和inorder()检查先序和中序遍历
        remove_tree(root);
    
    return 0;

  

以上是关于hdu1710 二叉树的主要内容,如果未能解决你的问题,请参考以下文章

二叉树hdu 1710 Binary Tree Traversals

HDU 1710 Binary Tree Traversals(二叉树)

HDU_1710_二叉树前序中序确定后序

算法漫游指北(第十三篇):二叉树的基本概念满二叉树完全二叉树二叉树性质二叉搜索树二叉树定义二叉树的广度优先遍历

树二叉树满二叉树完全二叉树遍历二叉树java实现

HDU 1710Binary Tree Traversals(已知前序中序,求后序的二叉树遍历)