hdu 1541 (cdq分治)

Posted wmj6

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1541 (cdq分治)相关的知识,希望对你有一定的参考价值。

Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

技术图片

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 

 

Sample Output
1 2 1 1 0
 

思路:

排序以后把在第二维上分治

技术图片
#include <bits/stdc++.h>
using namespace std;
const double pi = acos(-1.0);
const int N = 1e5+7;
const int inf = 0x3f3f3f3f;
const double eps = 1e-6;
typedef long long ll;
const ll mod = 1e9+7;
struct node
    int x,y,id;
    friend bool operator < (node a,node b)
        if(a.x!=b.x) return a.x<b.x;
        return a.y<b.y;
    
p[N],a[N];
int f[N];
int ans[N];
void cdq(int l,int r)
    if(l==r) return ;
    int mid=(l+r)>>1;
    cdq(l,mid); cdq(mid+1,r);
    int i=l,j=mid+1,cnt=l;
    while(i<=mid&&j<=r)
        if(p[i].y<=p[j].y)
            a[cnt++]=p[i++];
        else
            f[p[j].id]+=(i-l);
            a[cnt++]=p[j++];
        
    
    while(i<=mid) a[cnt++]=p[i++];
    while(j<=r)
        f[p[j].id]+=(i-l);
        a[cnt++]=p[j++];
     
    for(int k=l;k<=r;k++) p[k]=a[k];

int main()
//    ios::sync_with_stdio(false);
//    cin.tie(0); cout.tie(0);
    int n; 
    while(~scanf("%d",&n))
        memset(f,0,sizeof(f));
        memset(ans,0,sizeof(ans));
        for(int i=1;i<=n;i++)
            int x,y; scanf("%d%d",&x,&y);
            p[i]=nodex,y,i;
        
        sort(p+1,p+n+1);
        cdq(1,n);
        for(int i=1;i<=n;i++)
            ans[f[i]]++;
        for(int i=0;i<n;i++)
            printf("%d\n",ans[i]);    
    
        return 0;
View Code

 

以上是关于hdu 1541 (cdq分治)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 3507 Print Article(CDQ分治+分治DP)

HDU5730 FFT+CDQ分治

HDU Shell Necklace CDQ分治+FFT

Boring Class HDU - 5324 (CDQ分治)

hdu 4366 Successor - CDQ分治 - 线段树 - 树分块

HDU5322 Hope(DP + CDQ分治 + NTT)