POJ 1733锛堣竟甯︽潈骞舵煡闆?绂绘暎鍖栵級

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1733锛堣竟甯︽潈骞舵煡闆?绂绘暎鍖栵級相关的知识,希望对你有一定的参考价值。

鏍囩锛?a href='http://www.mamicode.com/so/1/where' title='where'>where   style   false   queue   span   tor   color   lang   decided   

Parity game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15492   Accepted: 5876

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend鈥榮 answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even鈥?or `odd鈥?(the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even鈥?means an even number of ones and `odd鈥?means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3
棰樼洰锛氫竴涓暱搴︿负n涓斿彧鐢?鍜?缁勬垚鐨勫簭鍒椼€傜敱m涓闂紝涓嬮潰m琛屼袱涓暟l锛宺锛屽拰even鎴栬€卭dd琛ㄧず闂尯闂磍鍒皉鏈夊鏁颁釜杩樻槸鍋舵暟涓?.姹傜殑涓€涓渶灏忕殑k锛屼娇寰楄繖涓?1搴忔弧瓒冲湪1鍒発涓棶棰橈紝鑰屼笉婊¤冻1鍒発+1涓棶棰?br />鎬濊矾锛歯寰堝ぇ锛宮灏忥紝鍏堢鏁e寲澶勭悊锛屽啀鐢ㄥ甫鏉冨苟鏌ラ泦
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <iomanip>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
#include <vector>
//const int maxn = 1e5+5;
#define ll long long
ll gcd(ll a,ll b)return b?gcd(b,a%b):a;
ll lcm(ll a,ll b)return a/gcd(a,b)*b;

#define MAX INT_MAX
#define FOR(i,a,b) for( int i = a;i <= b;++i)
#define bug cout<<"--------------"<<endl
using namespace std;
int n,m,t;
struct node

    int l,r;
    int ans; // ans琛ㄧず绗琲娆¤闂槸濂囪繕鏄伓
query[20010];
int tot;
//fa琛ㄧず骞舵煡闆? -锛宒銆恑銆戣〃绀簒涓巉a銆恑銆戠殑濂囧伓鎬у叧绯?/span>
int a[20010],fa[20010],d[20010];
void cinin() //绂绘暎鍖栦唬鐮?/span>

    scanf("%d %d",&n,&m);

    FOR(i,1,m)
    
        char c[20];
        scanf("%d %d %s",&query[i].l,&query[i].r,c);
        a[++tot] = query[i].l;
        a[++tot] = query[i].r;
        if(c[0] == 鈥?/span>o鈥?/span>) query[i].ans = 1;
        else query[i].ans = 0;
    
    sort(a+1,a+1+tot);
    tot = unique(a+1,a+1+tot) - a - 1;

int get(int x)

    if(x == fa[x]) return fa[x];
    int root = get(fa[x]);
    d[x] ^= d[fa[x]];
    return fa[x] = root;

int main()


    cinin();
    for(int i=1;i<=tot;i++) fa[i] = i;//娉ㄦ剰杩欓噷鏄痶ot涓嶆槸n
    for(int i =1;i<=m;i++)
    
        int x = lower_bound(a+1,a+1+tot,query[i].l-1) - a;//娉ㄦ剰鍖洪棿鏄?鍒發-1鍜屽尯闂?鍒皉锛屽乏闂彸寮€
        int y = lower_bound(a+1,a+1+tot,query[i].r) - a;
        int fx = get(x) , fy = get(y);
        if(fx == fy)
        
            if((d[x] ^ d[y]) != query[i].ans)
            
                cout<<i-1<<endl;
                return 0;
            
        
        else
        
            fa[fx] = fy;
            //a = b ^ c ^ d 绛変环浜?b = a ^ c ^ d 
            d[fx] = d[x] ^ d[y] ^ query[i].ans;
        
    
    cout<<m<<endl;



 


以上是关于POJ 1733锛堣竟甯︽潈骞舵煡闆?绂绘暎鍖栵級的主要内容,如果未能解决你的问题,请参考以下文章

CF884E Binary Matrix(骞舵煡闆?

POJ1733

poj1733

POJ1733Parity game

poj1733 Parity game

[2016-03-18][POJ][1733][Parity game]