PAT 1010 Radix 进制转换+二分法

Posted wkfvawl

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1010 Radix 进制转换+二分法相关的知识,希望对你有一定的参考价值。

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is “yes”, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of  the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set 0-9, a-z where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35.
The last number “radix” is the radix of N1 if “tag” is 1, or of N2 if “tag” is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print “Impossible”. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

 

#include<iostream>
#include<algorithm>
#include<string>
#include<cstdio>
#include<cmath>
#define ll long long
using namespace std;
ll convert(string n,ll radix)//转换为10进制的函数

    ll sum=0;
    int index=0,temp=0;
    for(auto it=n.rbegin(); it!=n.rend(); it++) //通过反向迭代器遍历
    
        if(*it>=0&&*it<=9)
        
            temp=*it-0;
        
        else
        
            temp=*it-a+10;
        
        sum+=temp*pow(radix,index++);
    
    return sum;

ll find_radix(string n,ll num)

    ll low,mid,high,t;
    char c=0;
    for(auto it=n.begin(); it!=n.end(); it++)
    
        if(*it>c)
        
            c=*it;
        
    
    if(c>=0&&c<=9)
    
        low=c-0+1;
    
    else
    
        low=c-a+10+1;
    
    high=max(low,num);
    while(low<=high)
    
        mid=(low+high)/2;
        t=convert(n,mid);
        if(t<0||t>num)
        
            high=mid-1;
        
        else if(t==num)
        
            return mid;
        
        else
        
            low=mid+1;
        
    
    return -1;


int main()

    string n1,n2;
    ll tag,radix,ans;
    cin>>n1>>n2>>tag>>radix;
    if(tag==1)
    
        ans=find_radix(n2,convert(n1,radix));
    
    else
    
        ans=find_radix(n1,convert(n2,radix));
    
    if(ans!=-1)
    
        printf("%lld",ans);
    
    else
    
        printf("Impossible");
    
    return 0;

 

以上是关于PAT 1010 Radix 进制转换+二分法的主要内容,如果未能解决你的问题,请参考以下文章

PAT甲级1010Radix

PAT 甲级测试题目 -- 1010 Radix

PAT甲级 1010 Radix

PAT甲级 1010 Radix

PAT 甲级1010 Radix (25分)

1010. Radix (25)(进制 + 二分 + 模拟)