PAT Advanced 1050 String Subtraction (20 分)

Posted littlepage

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT Advanced 1050 String Subtraction (20 分)相关的知识,希望对你有一定的参考价值。

Given two strings S?1?? and S?2??, S=S?1??S?2?? is defined to be the remaining string after taking all the characters in S?2?? from S?1??. Your task is simply to calculate S?1??S?2?? for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S?1?? and S?2??, respectively. The string lengths of both strings are no more than 1. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S?1??S?2?? in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.


#include <iostream>
using namespace std;

int main()
    string s1,s2,res="";
    getline(cin,s1);
    getline(cin,s2);
    for(int i=0;i<s1.length();i++)
        if(s2.find(s1[i])==s2.npos) res+=s1[i];
    
    cout<<res;
    system("pause");
    return 0;

 

 

以上是关于PAT Advanced 1050 String Subtraction (20 分)的主要内容,如果未能解决你的问题,请参考以下文章

PAT Advanced 1050 String Subtraction (20) [Hash散列]

PAT Advanced 1050 Broken Keyboard (20) [Hash散列]

PAT1050 : String Subtraction

pat 1050 String Subtraction(20 分)

PAT甲题题解-1050. String Subtraction (20)-水题

PAT甲级1050 String Subtraction (20 分)