C - Ekka Dokka

Posted YunYan

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了C - Ekka Dokka相关的知识,希望对你有一定的参考价值。

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that‘s why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of Nsquare centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print "Impossible" if they can‘t buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4

题目大意:就是判断一个数是否可以分解为一个奇数和一个偶数的乘积,并且使偶数最小

题解  先判断如果是奇数的话,直接输出impossible ,因为他不可能存在偶数因子,对于偶数,首先2是一个因子,然后循环除以2直到原数字变成了奇数就可以了

#include<iostream>
#include<cstdio>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
int main(){
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++){
        ll x;
        scanf("%lld",&x);
        
        if(x&1) {
            printf("Case %d: Impossible\n",i);
        }
        
        else {
            ll ans=1,t=1;
            while(x%2==0){
                x=x/2;
                ans*=2;
            }
            printf("Case %d: %lld %lld\n",i,x,ans);
        }
    }
    return 0;
}

 

以上是关于C - Ekka Dokka的主要内容,如果未能解决你的问题,请参考以下文章

使用Dokka为Kotlin代码生成KDoc

KDoc / Dokka:忽略子类中的继承方法

Dokka - 跳过为默认的 android 包生成 javadoc

如何向 Kotlin Dokka 文档添加页脚?

如何在 Kotlin 文档 Dokka/Kdoc 中转义符号?

无法让 dokka 在 gradle/android 项目上生成 kotlin 文档