Prime Distance

Posted accpted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Prime Distance相关的知识,希望对你有一定的参考价值。

题目描述

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

输入

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

输出

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

样例输入

2 17
14 17

样例输出

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

  

#include <bits/stdc++.h>

using namespace std;
typedef long long ll;
const  int maxn=500010;
int vis[1000100],prime[maxn],tot,a[maxn],num,minp,maxp;
void get_prime() 
    for (int i = 2; i <= 50000; i++) 
        if (!vis[i]) 
            prime[tot++] = i;
        
        for (int j = 0; j < tot && 1ll*i * prime[j] <= 50000; j++) 
            vis[i * prime[j]] = 1;
            if (i % prime[j] == 0) 
                break;
            
        
    

int main() 
    int l, r;
    get_prime();
    while (~scanf("%d%d", &l, &r)) 
        memset(vis, 0, sizeof(vis));
        for (int i = 0; i < tot; i++) 
            int p = prime[i];
            for (ll j = max(p * 2ll, (1ll*l + p - 1) / p * p); j <= r; j += p) 
                vis[j - l] = 1;
            
        
        num = 0;
        for (int i = 0; i <= r - l; i++) 
            if (!vis[i]&&i+l>1) 
                a[num++] = i+l;
            
        
        if (num < 2) 
            printf("There are no adjacent primes.\n");
            continue;
        
        minp = 0;
        maxp = 0;
        for (int i = 0; i + 1 < num; i++) 
            int d = a[i + 1] -a[i];
            if (d < a[minp + 1] - a[minp]) minp = i;
            if (d > a[maxp + 1] - a[maxp]) maxp = i;
        
        printf("%d,%d are closest, %d,%d are most distant.\n", a[minp], a[minp + 1], a[maxp], a[maxp + 1]);
    

  

以上是关于Prime Distance的主要内容,如果未能解决你的问题,请参考以下文章

打印质数

猩猩向参加 Cassandra Prime 活动的玩家开始推送 Prime 测试资格

大华 笔试小总结

模板欧拉筛

POJ 2689 Prime Distance

[BZOJ 1053] Anti-prime