1008 Elevator (20 分)

Posted tbhacker

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1008 Elevator (20 分)相关的知识,希望对你有一定的参考价值。

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41


#include<iostream>

using namespace std;

int main()
    int N;
    cin>>N;
    int sum=0;
    int st=0,last;
    while(N--)
        cin>>last;
        if(last>st)sum+=(last-st)*6;
        if(last<st)sum+=(st-last)*4;
        st=last;
        sum+=5;
    
    cout<<sum;

 

以上是关于1008 Elevator (20 分)的主要内容,如果未能解决你的问题,请参考以下文章

PAT甲级1008 Elevator (20分)

[PTA] PAT(A) 1008 Elevator (20 分)

1008 Elevator (20 分)

1008 Elevator (20分)

A1008 Elevator (20分)

1008 Elevator (20 分)难度: 简单 / 知识点: 模拟