1009 Product of Polynomials (25 分)

Posted tbhacker

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1009 Product of Polynomials (25 分)相关的知识,希望对你有一定的参考价值。

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (,) are the exponents and coefficients, respectively. It is given that 1, 0.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
double a[1001] =  0.0 , b[1001] =  0.0 , c[2001] =  0.0 ;



int main() 
    int k;
    cin >> k;
    int i, j;
    while (k--) 
        cin >> i;
        cin >> a[i];
    
    cin >> k;
    while (k--) 
        cin >> i;
        cin >> b[i];
    
    
    for (i = 0; i <= 1000; i++) 
        for (j = 0; j <= 1000; j++) 
            c[i+j] += a[i] * b[j];
        
    
    int cnt = 0;
    char str[1000] = "", str1[100];
    for (i = 2000; i >= 0; i--) 
        if (c[i] != 0.0) 
            sprintf(str1, " %d %0.1lf", i, c[i]);
            strcat(str, str1);
            cnt++;
        
    
    cout << cnt << str;

 

以上是关于1009 Product of Polynomials (25 分)的主要内容,如果未能解决你的问题,请参考以下文章

PAT1009:Product of Polynomials

1009 Product of Polynomials (25)(25 分)

1009 Product of Polynomials

1009 Product of Polynomials

1009 Product of Polynomials (25分) 多项式乘法

1009 Product of Polynomials (25 分)