POJ 区间DP Multiplication Puzzle

Posted oieredsion

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 区间DP Multiplication Puzzle相关的知识,希望对你有一定的参考价值。

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650




思路: 区间DP
则f[i][j] 表示i+1 到 j-1 已经被用掉
f[i][j]=min(f[i][j],f[i][k]+f[i][k]+a[i]*a[k]*a[j]);


code:
//
#include<iostream>
#include<cstdio>
#define maxnn 300 
int f[maxnn][maxnn];
int n;
int a[maxnn];
using namespace std;
int main()

    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            f[i][j]=1e9;
    for(int i=1;i<n;i++)
    f[i][i+1]=0;
    for(int i=n-1;i>=1;i--)
        for(int j=i+1;j<=n;j++)
            
                for(int k=i+1;k<j;k++)
                    f[i][j]=min(f[i][j],f[i][k]+f[k][j]+a[k]*a[i]*a[j]);
                    
              
    cout<<f[1][n];
    
  

 

以上是关于POJ 区间DP Multiplication Puzzle的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1651 Multiplication Puzzle (区间DP)

POJ 1651 - Multiplication Puzzle - [区间DP]

poj-1651 multiplication puzzle(区间dp)

Multiplication Puzzle POJ - 1651(区间DP)

POJ 1651 Multiplication Puzzle 区间DP

POJ 1651 Multiplication Puzzle 区间DP