HDU 2544 最短路

Posted cl0ud_z

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 2544 最短路相关的知识,希望对你有一定的参考价值。

题目

在每年的校赛里,所有进入决赛的同学都会获得一件很漂亮的t-shirt。但是每当我们的工作人员把上百件的衣服从商店运回到赛场的时候,却是非常累的!所以现在他们想要寻找最短的从商店到赛场的路线,你可以帮助他们吗?

Input

输入包括多组数据。每组数据第一行是两个整数N、M(N<=100,M<=10000),N表示成都的大街上有几个路口,标号为1的路口是商店所在地,标号为N的路口是赛场所在地,M则表示在成都有几条路。N=M=0表示输入结束。接下来M行,每行包括3个整数A,B,C(1<=A,B<=N,1<=C<=1000),表示在路口A与路口B之间有一条路,我们的工作人员需要C分钟的时间走过这条路。 
输入保证至少存在1条商店到赛场的路线。 

Output

对于每组输入,输出一行,表示工作人员从商店走到赛场的最短时间

Sample Input

2 1
1 2 3
3 3
1 2 5
2 3 5
3 1 2
0 0

Sample Output

3
2

思路

板子题

 

代码

#include <iostream>
#include <queue>
#include <utility>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;

struct edge
    int cost, to;
    edge(int _to, int _cost):to(_to), cost(_cost)
;
typedef pair<int, int> qnode; //first存距离,second存编号

vector<edge> G[110];
int dis[110];
int n, m;

void dij(int s)
    dis[s] = 0;
    fill(dis, dis + 110, INF);
    priority_queue<qnode, vector<qnode>, greater<qnode> > q;
    q.push(qnode(0, 1));
    while(!q.empty())
        qnode temp = q.top(); q.pop();
        if(temp.first > dis[temp.second]) continue;
        for(int i = 0; i < G[temp.second].size(); ++i)
            edge e = G[temp.second][i];
            if(dis[e.to] > temp.first + e.cost)
                dis[e.to] = temp.first + e.cost;
                q.push(qnode(dis[e.to], e.to));
            
        
    


int main() 
    while(cin >> n >> m)
        if(!n && !m) break;
        for(int i = 1; i <= 105; ++i)
            G[i].clear();
        int a, b ,c;
        for(int i = 1; i <= m; ++i)
            cin >> a >> b >> c;
            G[a].push_back(edge(b, c));
            G[b].push_back(edge(a, c));
        
        dij(1);
        cout << dis[n] << endl;
    
    return 0;

 

以上是关于HDU 2544 最短路的主要内容,如果未能解决你的问题,请参考以下文章

hdu 2544 最短路

HDU 2544 最短路

HDU 2544最短路 (迪杰斯特拉算法)

hdu2544---最短路

HDU 2544 最短路(Floyd算法)

hdu2544最短路(floyd基础)