Roads in the North (树的直径)

Posted staceyacm

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Roads in the North (树的直径)相关的知识,希望对你有一定的参考价值。

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
#define Inf 0x3f3f3f3f

const int maxn=1e4+5;
typedef long long ll;
using namespace std;
struct edge

    int to,cost;
;

vector<edge> e[maxn];
int farthest,ans;
void dfs(int x,int pre,int dis)

    for(int i=0;i<e[x].size();i++)
    
        int xx = e[x][i].to;
        if(xx == pre)
            continue;
        dfs(xx,x,dis+e[x][i].cost);
    
    if(dis > ans)
    
        ans = dis;
        farthest = x;
    

int main()

        int i,j;
       
        int x,y;
        edge t;
           while(scanf("%d%d%d",&x,&y,&t.cost)!=EOF)
           
            t.to = y;
            e[x].push_back(t);
            t.to = x;
            e[y].push_back(t);
            
        ans = 0;
        dfs(1,-1,0);
        
        dfs(farthest,-1,0);
        printf("%d\n",ans);
    
 
    return 0;

 

以上是关于Roads in the North (树的直径)的主要内容,如果未能解决你的问题,请参考以下文章

poj2631 ?Roads in the North(求树的直径)

poj Roads in the North 题解

POJ2631 Roads in the North

[Poj] Roads in the North

UVA10308 Roads in the North 树的最长路径

题解-CodeForces835F Roads in the Kingdom