HDU1250 Hat‘s Fibonacci (大数相加)(Java题解)

Posted jianqiao123

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1250 Hat‘s Fibonacci (大数相加)(Java题解)相关的知识,希望对你有一定的参考价值。

Hat‘s Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14587    Accepted Submission(s): 4853

Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input

Each line will contain an integers. Process to end of file.

Output

For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 

代码如下:

import java.math.BigInteger;
import java.util.Scanner;
public class Main
 static BigInteger f[]=new BigInteger[7045];
 public static void main(String[] args)
 dabiao();
 Scanner sc=new Scanner(System.in);
 while(sc.hasNext())
 int n=sc.nextInt();
 System.out.println(f[n]);
   
 
 private static void dabiao()
 f[1]=new BigInteger("1");
 f[2]=new BigInteger("1");
 f[3]=new BigInteger("1");
 f[4]=new BigInteger("1");
 for(int i=5;i<f.length;i++)
 f[i]=f[i-1].add(f[i-2]).add(f[i-3]).add(f[i-4]);
   
 

以上是关于HDU1250 Hat‘s Fibonacci (大数相加)(Java题解)的主要内容,如果未能解决你的问题,请参考以下文章

HDU1250 Hat‘s Fibonacci (大数相加)(Java题解)

HDOJ/HDU 1250 Hat's Fibonacci(大数~斐波拉契)

HDU 1250 Hat's Fibonacci (递推大数加法string)

(二维数组 亿进制 或 滚动数组) Hat's Fibonacci hdu1250

HDoj-1250-Hat&#39;s Fibonacci-大数

hdu 1250(大整数)