1051 Pop Sequence 入栈 出栈模拟

Posted liuzhaojun

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1051 Pop Sequence 入栈 出栈模拟相关的知识,希望对你有一定的参考价值。

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

#include <iostream>
#include <stack>
#include <vector>
using namespace std;
int main() 
    int m, n, k;
    scanf("%d %d %d", &m, &n, &k);
    for(int i = 0; i < k; i++) 
        bool flag = false;
        stack<int> s;
        vector<int> v(n + 1);
        for(int j = 1; j <= n; j++)
            scanf("%d", &v[j]);
        int current = 1;
        for(int j = 1; j <= n; j++) 
            s.push(j);
            if(s.size() > m) break;
            while(!s.empty() && s.top() == v[current]) 
                s.pop();
                current++;
            
        
        if(current == n + 1) flag = true;
        if(flag) printf("YES\n");
        else printf("NO\n");
    
    return 0;

被搞自闭了

以上是关于1051 Pop Sequence 入栈 出栈模拟的主要内容,如果未能解决你的问题,请参考以下文章

PAT甲题题解-1051. Pop Sequence (25)-堆栈

1051 Pop Sequence 需再做

PAT1051. Pop Sequence (25)

PAT 1051. Pop Sequence (25)

1051 Pop Sequence

1051 Pop Sequence