Poj 2406Power Strings

Posted wuhu-jjj

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Poj 2406Power Strings相关的知识,希望对你有一定的参考价值。

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 64676   Accepted: 26679

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

题解:KMP……照着书打的qwq

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
#define maxn 2000100
char s[maxn];
int nexts[maxn];
int n,m;
void getnexts()

    int j=0;
    int k=-1;
    nexts[0]=-1;
    while(j<m)
    
        if(k==-1||s[j]==s[k])
        
            j++;k++;
            nexts[j]=k;
        
        else k=nexts[k];
    

int main()

    while(~scanf("%s",s))
    
        if(s[0]==.)break;
        m=strlen(s);
        getnexts();
        int n=m-nexts[m];
        if(n!=m&&m%n==0)
            printf("%d\n",m/n);
        else
            printf("1\n");
    
    return 0;

 

以上是关于Poj 2406Power Strings的主要内容,如果未能解决你的问题,请参考以下文章

poj 2406 Power Strings

POJ——T 2406 Power Strings

POJ2406 Power Strings POJ1961 Period

POJ - 2406 Power Strings

poj 2406 Power Strings(KMP)

poj 2406 Power Strings