poj1742 多重背包的可行性问题

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj1742 多重背包的可行性问题相关的知识,希望对你有一定的参考价值。

http://poj.org/problem?

id=1742

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4
/**
poj 1742  多重背包的可行性问题
题目大意:给定n种面值的硬币面值分别为wi个数为ci。问用这些硬币能够组成1~m之间的多少面值
解题思路:楼教主的男人八题之中的一个。算是一个经典的问题,定义一个sum数组。每次填dp[j]时直接由dp[j-weight[i]]推出。
          前提是sum[j-w[i]]<c[i].sum每填一行都要清零。sum[j]表示当前物品填充j大小的包须要至少使用多少个.复杂度O(n*m)
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <iostream>
using namespace std;

int n,m;
int w[105],c[105],sum[100005],dp[100005];

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&w[i]);
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&c[i]);
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        int ans=0;
        for(int i=0;i<n;i++)
        {
            memset(sum,0,sizeof(sum));
            for(int j=w[i];j<=m;j++)
            {
                if(!dp[j]&&dp[j-w[i]]&&sum[j-w[i]]<c[i])
                {
                    dp[j]=1;
                    sum[j]=sum[j-w[i]]+1;
                    ans++;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


以上是关于poj1742 多重背包的可行性问题的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1742 Coins 多重背包DP

poj 1742 多重背包问题 dp算法

poj1742 Coins多重背包贪心

POJ 1742 Coins ( 经典多重部分和问题 && DP || 多重背包 )

Coins POJ - 1742 (背包判断可行性)

poj1742 Coins(多重背包+单调队列优化)